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Opening CHPS 
 
Objective: Use CHPS via a Virtual Network Computing (VNC) connection or NX client to provide forecast 
input. Contact the RFC for the IP address and password. 

 
STEP 1 Connect to Remote System 
Step Action Notes 

1 Ask your Service Hydrologist (SH) or Hydrologic Program Manager (HPM) 
for the log in credentials and launch CHPS from either an AWIPS or Linux 
workstation. 

 

2 Log into the workstation used for accessing CHPS.  

Step VNC Step NX 

3 Launch the VNC connection by typing the 
following command: 
 

vncviewer <remote IP address> 

3 Click the Red Hat icon and choose these 
from the popup menus:  

a. Internet 
b. NX Client 
c. NX Client Wizard 

4 Type the password at the command prompt in 
the VNC window. 
 

4 In the text entry boxes type: 
a. Session name 
b. IP address of host CHPS 
c. Select “WAN” from the slider 
d. Click “Next” 

 5 From this wizard window, select the 
following options: 

a. Unix 
b. Gnome 
c. Available Area 
d. Click “Next” 

6 In the next wizard window, type the 
following: 

a. login ID 
b. password 
c. session name chosen in Step 4 

 
STEP 2 Connect to the CHPS Master Controller 
Step Action Notes 

1 Open CHPS using the method in place at the host RFC.  Options include 
command line, desktop 
icon, or AWIPS start 
menu. 

2 Select a Master Controller and synchronization profile from the “Login to 
Master Controller” popup GUI. 

Defaults to primary MC/ 
full synch profile. 

3 Click “OK” and wait for the System Synchronization indicator (a cell in 
the lower right of the main CHPS GUI) to turn from magenta to green. 

Green indicates 
completed 
synchronization. 

4 Select a forecast group in the “Forecasts” panel and start analyzing 
segments. 
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Saving a Custom Layout 

Objective: Save a user-customized layout (not a configuration change) for future use. 

Save a Custom Layout 

Step Action Notes 

1 Open the CHPS Interactive Forecast Display (IFD) using the method in 
place at your office. 

 

2 Arrange the panels by dragging and dropping them into place. Keep arranging them 
until you find a layout 
you like. 

3 Save the layout changes by clicking the File menu and selecting Save 
Layout. 

 

 

4 Relaunch CHPS to verify the results. The interface should 
have the panels where 
you specified. 

Revert to the Default Layout 

Step Action Notes 

1 Open the CHPS Interactive Forecast Display (IFD) using the method in 
place at your office. 

 

2 Click the File menu and select Default Layout.  

3 Save the layout changes by clicking the File menu and selecting Save 
Layout. 
 

 

4 Relaunch CHPS to verify the results.  
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Editing Data Graphically 

Note: Make sure you are in Forecast Mode. You will not be able to make changes in View Mode! 
 
Caution: Undo Modifications does NOT work after clicking Save and Run! 
 

Preliminary Steps for All Graphical Editing Methods 
Step Action Notes 

1 Open the CHPS IFD.  

2 On the Forecasts panel, click a forecast group folder icon.  

3 Click the paper icon next to a segment in the Forecasts panel to select a 
location. 

 

4 Click the Plots tab.  

5 Click the edit options icon to get a drop down menu of editing options.

 

 

 

Editing the Time Series by Clicking 

This option works well for adding data that did not previously exist (for example, adding precipitation to a 
previously dry forecast). 

Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Click to select the first option, Edit the timeseries by clicking. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  
 

The editable parameter 
turns blue in the legend. 

4 Hover over the graph until you determine when you want the 
precipitation to start. 

 

5 Move the mouse up until you see the precipitation value you want to add.  

6 Left-click to put the precipitation value on the graph.  

7 Continue to left-click as you scroll, moving to the “zero” line for periods of 
no precipitation. 

 

8 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Editing the Time Series by Dragging a Point 

This option works well for editing existing data. 

Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Click to select the second option, Adjust the shape of the time series by 
dragging a selected point. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Left-click and hold on the data point you want to edit.  

5 Drag the point to a new location and release the left mouse button.  

6 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 

 

 

Setting Missing Between Selected Points 

Use this option to set bad or questionable values missing (better option: create a modifier to do this!). 
Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Click to select the third option, Set the value between selected points to 
missing. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Select the points between which you want to delete data.  

5 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Linearly Interpolate Between Points 

This is a good option for creating a realistic curve when “drawing in” data. 

Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Click to select the fourth option, Linear interpolate between selected 
points. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Select the points you want to interpolate between.  

5 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 

 

 

Quadratically Interpolate Between Points 

This provides a different mathematical solution when interpolating between points. 
Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Click to select the fifth option, Quadratic interpolate between selected 
points. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Select the points you want to interpolate between.  

5 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Editing Data in the Table 

Objective: Edit data in a table for more precision than graphical editing. 
 
This option works well for adding data that did not previously exist (for example, adding precipitation to a 
previously dry forecast), or adding more precision to what is already in the table. 
 

Step Action Notes 

1 Open the CHPS IFD.  

2 Click the paper icon next to a segment in the Forecasts panel to select a 
location. 

 

3 Click the Plots tab.  

4 From the list in the legend, left-click the time series you want to edit.  

5 Click F7 OR the table icon. 

 

 

6 Locate the element and time you want to edit. You may need to scroll in 
the table to find the element. 

The header is the same 
color as the time series 
trace and the selected 
element’s cells in the 
table are white (not 
grey). 

7 Click in the table.  

8 Use the keypad to input numerical values.  

9 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Creating Modifiers 

Objective: Create modifiers so the model more accurately represents stage and flow. 
 
Note: Modifiers are created and edited using various methods. The methods are similar to editing time 
series plots.  
 

Create a New Modifier 
Step Action Notes 

1 Start CHPS using either method from Lesson 1.  

2 Select the icon (Map panel) or segment name (Forecast tab) 
corresponding to the desired forecast point. 

 

3 Click a modifier type button on the Modifiers GUI or select Create Mod 
and select one from the pull-down menu. 

More options on the 
pull-down menu. 

4 Type a name in the Modifier Properties box. Optional 

5 Select a start time using the calendar or the up/down arrow selectors. The date format is MM-
DD-YYYY HH:MM:SS. 

6 Select an end time using the same technique. Some mods do not have 
a selectable end time. 

7 Edit the properties of the modifier using slider bars, text entry boxes, 
clicking on the graphic, or editing tabular data. 

Edit method varies by 
modifier type. 

8 Click Apply to and choose segments by clicking in the boxes next to the 
segment name. 

 

9 Click Rerun. This applies the modifier. 

 

Deactivate Modifiers 
Step Action Notes 

1 Locate the modifier in the list.  

2 Click the check mark in the Active column of the modifiers list.  

3 Click Rerun. This deactivates the 
modifier. 

 

Copy Modifiers 
Step Action Notes 

1 Locate the modifier in the list.  

2 Click the paper icon in the Copy column of the modifiers list. Nothing in the filename 
indicates this is a copy. 

 

Delete Modifiers 
Step Action Notes 

1 Locate the modifier in the list.  

2 Click the red X in the Delete column of the modifiers list.  

3 Click Rerun. This permanently deletes 
the modifier. 
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Creating Forecast Input 

Objective: Create input to hydrologic forecasts. 
 
Note: Grey shading indicates optional steps. 
 

Step Action Notes 

1 Open CHPS using your preferred method.   

2 After initial synching completes, click the Tools menu and select Manual 
Forecast. 

Optional steps to import 
additional data. 

2b Select a workflow from the Workflow pull-down menu. 

2c Select a subbasin. 

2d In the State selection part of the GUI, click the checkbox next to Select 
initial state. 

2e Use the radio buttons and up/down arrows to select the state and the run 
start and end times. 

3 Click the folder, labeled with the name of your servicing RFC, in the 
Forecast panel. 

The area to select a Run 
Option becomes 
available. 

4 Click the Run Options button to select an initial state. Only if using states other 
than the default. 

5 Use the radio buttons and/or calendar to make a selection. Only if using states other 
than the default. 

6 Select the forecast group from the Forecast panel. This makes the Plots tab 
active. 

7 Click OK.  

8 Click Rerun forecast group to do all the calculations so you can go 
through the segments quicker. 

Optional step, but 
considered a best 
practice at many offices. 

9 Double click either the name of the segment or the icon.  

10 Click the Plot Overview panel. Gives you thumbnails of 
all of the parameters 
available at the location. 

11 Reposition the overview by dragging it to the top of the plot, or to the 
right or left side. 

Click and drag where 
other panels are located. 
If you release over the 
active tab, it will not be 
repositioned. 

12 Make modifiers as needed. See modifiers job sheet 
for specific help. 
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13 Click the Next segment button to look through the segments. 
 

See the lesson on 
analysis for more details.  
Use the F4 key to 
advance through the 
segments; F3 to see the 
previous segment. 

14 Scroll back to the top of the segment list, and click on the forecast group 
folder icon. 

 

15 Note any input for the RFC forecast.  

16 From the Modifiers tab, delete any modifiers you made.  

17 Close CHPS. From the File menu, select Log out. The keyboard shortcut 
for this command is 
Cntrl+M. 

18 On the top of the VNC screen, click the X to disconnect.  

 

 

 

 

 

 

http://www.nwstc.noaa.gov/CHPS/wfo_user/lesson2/analysis.html

