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Opening CHPS  
 
Objective: Use one of these methods to open CHPS and begin forecasting. 
 

Starting CHPS from the Command Line 
Step Action Notes 

1 Log into an AWIPS workstation using your username and password.  

2 Left-click on the background, and select Terminal from the popup menu.  

3 Navigate to the OC directory. 
 
cd /awips/chps_share/oc/username 

 

4 Type the following command: 
 
./bin/fews.sh xxrfc_oc 

 

5 Select a Master Controller and synchronization profile from the Login to 
Master Controller popup GUI. 

Defaults to primary MC/ 
full synch profile. 

6 Click OK, and wait for the System Synchronization indicator (a cell in the 
lower right of the main CHPS GUI) to turn from magenta to green. 

Green indicates 
completed 
synchronization. 

7 Select a forecast group in the Forecasts panel and start analyzing 
segments. 

 

 

Starting CHPS from the AWIPS Startup Menu 
Step Action Notes 

1 Log into an AWIPS workstation using your username and password.  

2 Left-click on the background, and select AWIPS start-up menu from the 
popup menu. 

 

3 Scroll to the CHPS start application.  
 

For example: 
xxrfc_chps(localapp) 

4 Select a Master Controller and synchronization profile from the Login to 
Master Controller popup GUI. 

Defaults to primary MC/ 
full synch profile. 

5 Click OK, and wait for the System Synchronization indicator to turn from 
magenta to green. 

Green indicates 
completed 
synchronization. 

6 Select a forecast group in the Forecasts panel and start analyzing 
segments. 

 

 
Note: Starting CHPS from the AWIPS Startup Menu requires edits to an AWIPS file. Ask your AWIPS Focal 
Point if you want this option at your office! 
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Creating a LocalApp Menu Item to Open CHPS 
 
Note: This is a System Administrator task.  
 

STEP 1 Creating the “run_chps” File 

Step Action Notes 

1 Log into an AWIPS workstation using your user name and password.  

2 Left-click on the background, and select Terminal from the popup menu.  

3 Navigate to the directory where you want the run_chps file to reside. 
 

cd /awips/chps_share/oc 

 

4 Create a new file to house the script. 
 

gedit run_chps 

Gedit is one example of 
an editor – vi also works. 

5 Add the following lines to the newly created file: 
 

#!/bin/sh 
 
cd /awips/chps_share/oc/$USER 
./bin/fews.sh xxrfc_oc 

Where xxrfc is the 
identifier of your OC 
instance. 

6 Save and exit.  

 
STEP 2 Editing the Local AppLauncher Script 
Step Action Notes 

1 Navigate to the directory containing the AppLauncher scripts. 
 

cd /awips/fxa/data/appLauncher 

 

2 Edit the local.conf file using your preferred editor. 
 

gedit local.conf 

This example uses Gedit. 

3 Scroll to the bottom of the file and add the following lines: 
 

START_RECORD 
Name=run_chps(localapp) 
Exec=/awips/chps_share/oc/run_chps 
END_RECORD 

Most of the file is 
comments. 

4 Save and exit.  
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STEP 3 Verifying Functionality 

Step Action Notes 

1 Close all CHPS instances.  

2 Left-click on the background, and select AWIPS start-up menu from the 
popup menu. 

 

3 Choose run_chps(localapp) from the popup menu.  

4 Verify the CHPS OC opens for the user currently logged into AWIPS. 
 
If the application does not open, check the following items: 
● Make sure the AWIPS login and the CHPS user accounts match. For 

instance, if you are logged into FEWS, you cannot launch CHPS as a 
user. 

Is the directory for the user’s OC named the same as their AWIPS login? If 
you name the directory containing the OC instance “George” instead of 
their user name, “gmurphy”, CHPS will not open. 
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Saving a Custom Display Layout 
 
Objective: Save a user-customized layout (not a configuration change) for future use. 
 

Step Action Notes 

1 Open the CHPS Interactive Forecast Display (IFD) using the method in 
place at your office. 

Some RFCs launch from 
the left-click menu in 
AWIPS. 

2 Arrange the panels by dragging and dropping them into place. Keep arranging them 
until you find a layout 
you like. 

3 Save the layout changes by clicking the File menu and selecting Save 
Layout. 

 

 

4 Relaunch CHPS. The interface should 
have the panels where 
you specified. 

Note: Revert to the default layout by selecting Default Layout, from the File menu. 
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Editing Data Graphically 
 
Changing information is a necessary part of the forecast process. CHPS offers several ways of editing. 
 
Note: Make sure you are in Forecast Mode. You will not be able to make changes in View Mode! 
Caution: Undo Modifications does NOT work after clicking Save and Run! 
 

Preliminary Steps for All Graphical Editing Methods 
Step Action Notes 

1 Open the CHPS IFD.  

2 On the Forecasts panel, click a forecast group folder icon.  

3 Click the paper icon next to a segment in the Forecasts panel to select a 
location. 

 

4 Click the Plots tab.  

5 Click the edit options icon to get a drop down menu of editing options.

 

 

 

Editing the Time Series by Clicking 
This option works well for adding data that did not previously exist (for example, adding precipitation to 
a previously dry forecast). 
Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Select the first option, Edit the timeseries by clicking. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  
 

The editable parameter 
turns blue in the legend. 

4 Hover over the graph until you determine when you want the 
precipitation to start. 

 

5 Move the mouse up until you see the precipitation value you want to add.  

6 Left-click to put the precipitation value on the graph.  

7 Continue to left-click as you scroll, moving to the “zero” line for periods of 
no precipitation. 

 

8 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Editing the Time Series by Dragging a Point 
This option works well for editing existing data. 
Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Select the second option, Adjust the shape of the time series by dragging 
a selected point. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Left-click and hold on the data point you want to edit.  

5 Drag the point to a new location and release the left mouse button.  

6 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 

 

 

Setting Missing Values Between Selected Points 
Use this option to set bad or questionable values missing (better option: create a modifier to do this!). 
Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Select the third option, Set the value between selected points to missing. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Select the points between which you want to delete data.  

5 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Linearly Interpolating Between Points 
This is a good option for creating a realistic curve when “drawing in” data. 
Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Select the fourth option, Linear interpolate between selected points. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Select the points you want to interpolate between.  

5 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 

 

 

Quadratically Interpolating Between Points 
This provides a different mathematical solution when interpolating between points. 
Step Action Notes 

1 Complete Steps 1 through 5 from the Preliminary Steps table.  

2 Select the fifth option, Quadratic interpolate between selected points. 

 

 

3 From the list in the legend, left-click the time series you want to edit.  

4 Select the points you want to interpolate between.  

5 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Editing the Time Series in the Data Table 

Objective: Edit data in a table for more precision than graphical editing. 
 
This option works well for adding data that did not previously exist (for example, adding precipitation to 
a previously dry forecast), or adding more precision to what is already in the table. 
 
Step Action Notes 

1 Open the CHPS IFD.  

2 Click the paper icon next to a segment in the Forecasts panel to select a 
location. 

 

3 Click the Plots tab.  

4 From the list in the legend, left-click the time series you want to edit.  

5 Click F7 OR the table icon.

 

 

6 Locate the element and time you want to edit. You may need to scroll in 
the table to find the element. 

The header is the same 
color as the time series 
trace, and the selected 
element’s cells in the 
table are white (not 
grey). 

7 Click in the table.  

8 Use the keypad to input numerical values.  

9 Click the Save Changes and Run icon to save the changes OR the Undo 
Modifications icon to abandon the changes. 
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Creating Modifiers 

Objective: Create modifiers so the model more accurately represents stage and flow.  
 
Note: Modifiers are created and edited using various methods. The methods are similar to editing time 
series plots. Grey shading indicates optional steps. 
 

Creating a New Modifier 
Step Action Notes 

1 Start CHPS using either method from Lesson 1.  

2 Select the icon (Map panel) or segment name (Forecast tab) 
corresponding to the desired forecast point. 

 

3 Click a modifier type button on the Modifiers GUI or select Create Mod 
and select one from the pull-down menu. 

More options on the 
pull-down menu. 

4 Type a name in the Modifier Properties box. Optional. 

5 Select a start time using the calendar or the up/down arrow selectors. The date format is MM-
DD-YYYY HH:MM:SS. 

6 Select an end time using the same technique. Some mods do not have 
a selectable end time. 

7 Edit the properties of the modifier using slider bars, text entry boxes, 
clicking on the graphic, or editing tabular data. 

Edit method varies by 
modifier type. 

8 Click Apply to apply the modifier to the selected segment only OR click 
Apply to and choose segments by clicking in the boxes next to the 
segment name. 

 

9 Click OK. This applies the modifier. 

10 View the hydrograph and repeat steps 7 through 9 until you think the 
hydrograph is more representative. 

 

 

Deactivating Modifiers 
Step Action Notes 

1 Locate the modifier in the list.  

2 Click the check mark in the Active column of the modifiers list.  

 

Deleting Modifiers 
Step Action Notes 

1 Locate the modifier in the list.   

2 Click the red X in the Delete column of the modifiers list.  

 
Copying Modifiers 
Step Action Notes 

1 Locate the modifier in the list.   

2 Click the paper icon in the Copy column of the modifiers list. Nothing in the filename 
indicates this is a copy. 

 
See the SACSMA and API modifiers documents for additional information on modifiers. 
 

  

http://www.nwstc.noaa.gov/CHPS/apimods.pdf
http://www.nwstc.noaa.gov/CHPS/apimods.pdf
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Creating Forecasts 
 
Objective: Create hydrologic forecasts of varying types, such as water supply forecasts, and forecast 
periods. 
 
The basic method of creating a forecast is the same, whether the forecast period is 5 days or 30.  
 
Grey shading indicates optional steps. 
 

Creating a Daily Forecast 
Step Action Notes 

1 Open CHPS using your preferred method.   

2 After initial synching completes, click the Tools menu and select Manual 
Forecast. 

Optional steps to import 
additional data. 

2b Select a workflow from the Workflow pull-down menu. 

2c Select a subbasin. 

2d In the State selection part of the GUI, click the checkbox next to Select 
initial state. 

2e Use the radio buttons and up/down arrows to select the state and the run 
start and end times. 

3 Click the RFC folder in the Forecast panel. The area to select a Run 
Option becomes 
available. 

4 Click the Run Options button to select an initial state. Only if using states other 
than the default. 

5 Use the radio buttons and/or calendar to make a selection. Only if using states other 
than the default. 

6 Select the forecast group from the Forecast panel. This makes the Plots tab 
active. 

7 Click OK.  

8 Click Rerun forecast group to do all the calculations so you can go 
through the segments quicker. 

Optional step, but 
considered a best 
practice at many offices. 

9 Double click either the name of the segment or the icon.  

10 Click the Plot Overview panel. Gives you thumbnails of 
all of the parameters 
available at the location. 

11 Reposition the overview by dragging it to the top of the plot, or to the 
right or left side.  

Click and drag where 
other panels are located. 
If you release over the 
active tab, it will not be 
repositioned. 

12 Make modifiers as needed.  
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13 Click the Next segment button to look through the segments. 
 

Use the F4 key to 
advance through the 
segments; F3 to see the 
previous segment. 

14 Scroll back to the top of the segment list and click on the forecast group 
folder icon. 

See lesson on analysis 
for more details. 

15 Click the Run Approved Forecast button after completing analysis and 
editing.  

 

16 Wait until you get a green checkmark beside the forecast group 
folder.  

 

16 Click the Forecast Management button, or select it from the Tools menu. The keyboard shortcut 
for this command is 
Cntrl+F. 

17 Look on Current Forecasts tab to make sure the forecast made it to the 
Central Database. 

Click here for a link to 
the icon legend.  

18 Close CHPS. From the File menu, select Log out. The keyboard shortcut 
for this command is 
Cntrl+M. 

 
  

http://publicwiki.deltares.nl/display/FEWSDOC/07+Forecast+Manager
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Creating Supplemental Forecast Products 
 
Objective: Create the supplemental forecasts produced at your office.  
 

Creating a Contingency Forecast  
Step Action Notes 

1 Create the contingency QPF using GFE. Contact the GFE focal 
point at your office if you 
need help with this step. 

2 Follow the same procedure for a daily forecast.   

3 From the Tools menu, select Manual Forecast.  

4 Select a workflow from the pull-down menu to import additional QPF.  

 
Creating a Water Supply Forecast 
Step Action Notes 

1 Follow the same procedure for a daily forecast.   

2 From the Tools menu, select Manual Forecast.  

3 Select a workflow from the pull-down menu to import historical data.  

 
Creating a Long Range Forecast 
Step Action Notes 

1 Follow the same procedure for a daily forecast.   

2 From the Tools menu, select Manual Forecast.  

3 Change the date to 28 days.  

 
Creating an Ensemble Forecast 
Step Action Notes 

1 Follow the same procedure for a daily forecast.   

2 From the Tools menu, select Manual Forecast.  

3 Select a workflow from the pull-down menu to import additional data.  
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What-If Scenarios 
 

Objective: Use What-If Scenarios to explore forecast possibilities. 

STEP 1 Creating Scenarios 
Step Action Notes 

1 Start CHPS using your preferred method.  

2 From the Tools menu, select What-if Scenario. The keyboard shortcut 
for this command is 
Cntrl+W. 

3 From the What-if Scenario GUI, select Add New Scenario. Give the scenario a 
logical, representative 
name. 

4 Click OK.  

Create a Transformation Select Module Datasets 

5 In the Transformation tab, choose the 
following: 
 
input time series 
location set or all locations 
operator 
value 

5 Click Select Module Data Set File for other 
data. 
 
Only data sets loaded into the database 
through the Configuration Manager appear 
in the pull-down list. 

Step Action Notes 

6 Click Add to List.  

7 Click Save Scenario.  Unsaved scenarios are 
listed in blue text; saved 
scenarios in magenta. 

STEP 2 Running the Scenario 
Step Action Notes 

1 From the Tools menu, select Manual Forecast. The keyboard shortcut 
for this command is 
Cntrl + N. 

2 Select a workflow with which to run the scenario.  

3 Choose a transformation or other option (module parameters, datasets, 
etc.) from the pull-down menu. 

 

4 Click Run.  

 
STEP 3 Managing Scenarios 
The number of What-if Scenarios in the system can become quite large. Limit the number of visible 
What-if Scenarios by deleting scenarios or making them invisible to all users. 
Step Action Notes 

1 In the What-if Scenario interface, click the Edit Visibility button.  

2 Click Toggle Visible to make the selected what-if scenario invisible to 
users.  
 

Invisible scenario 
names are greyed out. 

3 Click Toggle Delete to delete scenarios from the system permanently. 
 

While the interface is 
still open, scenarios are 
marked with D. 
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Reporting Problems on FogBugz 
 
Objective: Report issues on the FogBugz web site, providing as much pertinent information as possible. 
 

STEP 1 Log On to the FogBugz Website 

Step Action Notes 

1 From an internet browser, go to Schuylkill.nws.noaa.gov:7069 If the page does not 
load, send it again. 

2 Log in using the RFC username and password. 

 

Box is in the upper right 
corner. 
 

 

STEP 2 Search for Relevant Cases 
Note: In Internet Explorer, the search function only works in Compatibility mode. 

Step Action Notes 

1 Type a keyword 
associated with the 
topic/problem in the 
upper right search box. 

Documents will be 
listed first, then cases. 
 

2 If a case is located, look through the status to see if it is still in progress 
or has been solved. Also, check the notes in the case. 

 

3 Track the progress of cases similar to the problems at your RFC by 
clicking the Subscribe button on the left side.  

 

4 If the search yields no similar cases, add a case.  
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STEP 3 Submit a New Case 
Step Action Notes 

1 Click New Case on the top navigation bar.  

2 Name the case the main topic of the problem. Labeled 1 on Figure 11. 

3 Select CHPS-bugz in the Project drop down menu. Labeled 2 on Figure 11. 

4 Select the area relating to the issue. Labeled 3 on Figure 11. 

5 Choose a category. Labeled 4 on Figure 11. 

6 Enter your name. Labeled 5 on Figure 11. 

7 Enter your RFC ID. Labeled 6 on Figure 11. 

8 Describe the issue, in depth. Make sure to note where, when, how, what 
directories or files are involved, and its impact. 

Labeled 7 on Figure 11. 

9 Set a priority. Labeled 8 on Figure 11. 

10 Make sure to include tags for easier searching. Labeled 9 on Figure 11. 

11 Change the priority, add more users, and attach a file. Labeled 10 on Figure 
11. 

12 Click OK. Labeled 11 on Figure 
11. 

Figure 11 

 
 


